import Foundation
let pattern = ##"^(?!.*?\.).*?(#.*\w*[a-zA-Z_]+\w*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
hello#music
#hello#music
hello.com#music -> no match
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)