const regex = /^(?!.*?\.).*?(#.*\w*[a-zA-Z_]+\w*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?\\.).*?(#.*\\w*[a-zA-Z_]+\\w*)', 'gm')
const str = `hello#music
#hello#music
hello.com#music -> no match`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);