package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z][a-z0-9]*([._-][a-z0-9]+)*$`)
var str = `abcde1
abcde
abc.de
abc.de-uu8_1
abc.de-uu8_12
abcde_
_abcde
abcde.
.abcde
ww_.abcde
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}