import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z][a-z0-9]*([._-][a-z0-9]+)*$";
final String string = "abcde1\n"
+ "abcde\n"
+ "abc.de\n"
+ "abc.de-uu8_1\n"
+ "abc.de-uu8_12\n"
+ "abcde_\n"
+ "_abcde\n"
+ "abcde.\n"
+ ".abcde\n"
+ "ww_.abcde\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}