import re
regex = re.compile(r"^[a-z][a-z0-9]*([._-][a-z0-9]+)*$", flags=re.MULTILINE)
test_str = ("abcde1\n"
"abcde\n"
"abc.de\n"
"abc.de-uu8_1\n"
"abc.de-uu8_12\n"
"abcde_\n"
"_abcde\n"
"abcde.\n"
".abcde\n"
"ww_.abcde\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")