re = /^[a-z][a-z0-9]*([._-][a-z0-9]+)*$/m
str = 'abcde1
abcde
abc.de
abc.de-uu8_1
abc.de-uu8_12
abcde_
_abcde
abcde.
.abcde
ww_.abcde
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end