// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z][a-z0-9]*([._-][a-z0-9]+)*$").unwrap();
let string = "abcde1
abcde
abc.de
abc.de-uu8_1
abc.de-uu8_12
abcde_
_abcde
abcde.
.abcde
ww_.abcde
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}