using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA.";
string substitution = @"data1: ${data1}\ndata2: ${data2}";
string input = @"ISA~this is date~ESA|ISA~this is more data~ESA|";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}