// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA.").unwrap();
let string = "ISA~this is date~ESA|ISA~this is more data~ESA|";
let substitution = "data1: ${data1}\\ndata2: ${data2}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}