$re = '/ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA./';
$str = 'ISA~this is date~ESA|ISA~this is more data~ESA|';
$subst = "data1: ${data1}\ndata2: ${data2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;