import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA.";
final String string = "ISA~this is date~ESA|ISA~this is more data~ESA|";
final String subst = "data1: ${data1}\\ndata2: ${data2}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}