const regex = /ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA.', 'g')
const str = `ISA~this is date~ESA|ISA~this is more data~ESA|`;
const subst = `data1: ${data1}\ndata2: ${data2}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);