import re
regex = re.compile(r"ISA(?<data1>.*?)ESA.ISA(?<data2>.*?)ESA.")
test_str = "ISA~this is date~ESA|ISA~this is more data~ESA|"
subst = "data1: ${data1}\\ndata2: ${data2}"
result = regex.sub(subst, test_str)
if result:
print(result)