# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/href="\//href="http:\/\/example.com\//si;t' <<< "test <a href=\"/web/data.html\">link1</a> <a href=\"http://google.com/test\">link2</a>
"