$re = '~href="/~si';
$str = 'test <a href="/web/data.html">link1</a> <a href="http://google.com/test">link2</a>
';
$subst = "href=\"http://example.com/";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;