using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""/";
string substitution = @"href=""http://example.com/";
string input = @"test <a href=""/web/data.html"">link1</a> <a href=""http://google.com/test"">link2</a>
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}