re = /href="\//i
str = 'test <a href="/web/data.html">link1</a> <a href="http://google.com/test">link2</a>
'
subst = 'href="http://example.com/'
result = str.sub(re, subst)
# Print the result of the substitution
puts result