import re
regex = re.compile(r"href=\"/", flags=re.DOTALL | re.IGNORECASE)
test_str = ("test <a href=\"/web/data.html\">link1</a> <a href=\"http://google.com/test\">link2</a>\n\n")
subst = "href=\"http://example.com/"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)