use strict;
my $str = 'test <a href="/web/data.html">link1</a> <a href="http://google.com/test">link2</a>
';
my $regex = qr~href="/~sip;
my $subst = 'href="http://example.com/';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";