const regex = new RegExp('href="/', 'si')
const str = `test <a href="/web/data.html">link1</a> <a href="http://google.com/test">link2</a>
`;
const subst = `href="http://example.com/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);