// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?si)href="/"#).unwrap();
let string = "test <a href=\"/web/data.html\">link1</a> <a href=\"http://google.com/test\">link2</a>
";
let substitution = "href=\"http://example.com/";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}