#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([a-fA-F0-9]{0,4}[:]){4,7}([a-fA-F0-9]{0,4})$"
Local $sString = "2001:0000:3238:DFE1:63:0000:0000:FEFB" & @CRLF & _
"2001:0000:3238:DFE1:363:0:0000:FEFB" & @CRLF & _
"2001:0000:3238:DFE1:63::FEFB" & @CRLF & _
"2001:0:3238:DFE1:63::FEFB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")