import re
regex = re.compile(r"^([a-fA-F0-9]{0,4}[:]){4,7}([a-fA-F0-9]{0,4})$")
test_str = ("2001:0000:3238:DFE1:63:0000:0000:FEFB\n"
"2001:0000:3238:DFE1:363:0:0000:FEFB\n"
"2001:0000:3238:DFE1:63::FEFB\n"
"2001:0:3238:DFE1:63::FEFB")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")