use strict;
my $str = '2001:0000:3238:DFE1:63:0000:0000:FEFB
2001:0000:3238:DFE1:363:0:0000:FEFB
2001:0000:3238:DFE1:63::FEFB
2001:0:3238:DFE1:63::FEFB';
my $regex = qr/^([a-fA-F0-9]{0,4}[:]){4,7}([a-fA-F0-9]{0,4})$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}