import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-fA-F0-9]{0,4}[:]){4,7}([a-fA-F0-9]{0,4})$";
final String string = "2001:0000:3238:DFE1:63:0000:0000:FEFB\n"
+ "2001:0000:3238:DFE1:363:0:0000:FEFB\n"
+ "2001:0000:3238:DFE1:63::FEFB\n"
+ "2001:0:3238:DFE1:63::FEFB";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}