// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([a-fA-F0-9]{0,4}[:]){4,7}([a-fA-F0-9]{0,4})$").unwrap();
let string = "2001:0000:3238:DFE1:63:0000:0000:FEFB
2001:0000:3238:DFE1:363:0:0000:FEFB
2001:0000:3238:DFE1:63::FEFB
2001:0:3238:DFE1:63::FEFB";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}