using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-fA-F0-9]{0,4}[:]){4,7}([a-fA-F0-9]{0,4})$";
string input = @"2001:0000:3238:DFE1:63:0000:0000:FEFB
2001:0000:3238:DFE1:363:0:0000:FEFB
2001:0000:3238:DFE1:63::FEFB
2001:0:3238:DFE1:63::FEFB";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}