# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^IT [0-9]{1,5}\\/(?:19|20)\d{2}\((?:MN|[HB-EGKMUNLSTV])\)/ /gm;t' <<< "IT 1/2014(G)
or
IT 1/2014(MN)"