re = /^IT [0-9]{1,5}\/(?:19|20)\d{2}\((?:MN|[HB-EGKMUNLSTV])\)/m
str = 'IT 1/2014(G)
or
IT 1/2014(MN)'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result