import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^IT [0-9]{1,5}\\/(?:19|20)\\d{2}\\((?:MN|[HB-EGKMUNLSTV])\\)";
final String string = "IT 1/2014(G)\n\n"
+ "or\n\n"
+ "IT 1/2014(MN)";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}