#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^IT [0-9]{1,5}\/(?:19|20)\d{2}\((?:MN|[HB-EGKMUNLSTV])\)"
Local $sString = "IT 1/2014(G)" & @CRLF & _
"" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"IT 1/2014(MN)"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)