const regex = /^IT [0-9]{1,5}\/(?:19|20)\d{2}\((?:MN|[HB-EGKMUNLSTV])\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^IT [0-9]{1,5}\\\/(?:19|20)\\d{2}\\((?:MN|[HB-EGKMUNLSTV])\\)', 'gm')
const str = `IT 1/2014(G)
or
IT 1/2014(MN)`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);