use strict;
my $str = 'IT 1/2014(G)
or
IT 1/2014(MN)';
my $regex = qr/^IT [0-9]{1,5}\/(?:19|20)\d{2}\((?:MN|[HB-EGKMUNLSTV])\)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";