#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*?),(.*)"
Local $sString = "Geranium, Ivy" & @CRLF & _
"Geranium, Zonal" & @CRLF & _
"Geranium, Interspecific" & @CRLF & _
"Impatiens, New Guinea" & @CRLF & _
"Petunia, Trailing" & @CRLF & _
"Petunia, Spreading" & @CRLF & _
"Petunia, Miniature Trailing" & @CRLF & _
"Impatiens, Interspecific New Guinea" & @CRLF & _
"Mum, Garden" & @CRLF & _
"Mum, Pot" & @CRLF & _
"Combinations, Vigorous"
Local $sSubst = "\2 \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)