using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?),(.*)";
string substitution = @"\2 \1";
string input = @"Geranium, Ivy
Geranium, Zonal
Geranium, Interspecific
Impatiens, New Guinea
Petunia, Trailing
Petunia, Spreading
Petunia, Miniature Trailing
Impatiens, Interspecific New Guinea
Mum, Garden
Mum, Pot
Combinations, Vigorous";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}