import Foundation
let pattern = #"(.*?),(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Geranium, Ivy
Geranium, Zonal
Geranium, Interspecific
Impatiens, New Guinea
Petunia, Trailing
Petunia, Spreading
Petunia, Miniature Trailing
Impatiens, Interspecific New Guinea
Mum, Garden
Mum, Pot
Combinations, Vigorous
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2 \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)