use strict;
my $str = 'Geranium, Ivy
Geranium, Zonal
Geranium, Interspecific
Impatiens, New Guinea
Petunia, Trailing
Petunia, Spreading
Petunia, Miniature Trailing
Impatiens, Interspecific New Guinea
Mum, Garden
Mum, Pot
Combinations, Vigorous';
my $regex = qr/(.*?),(.*)/mp;
my $subst = '\\2 \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";