$re = '/(.*?),(.*)/m';
$str = 'Geranium, Ivy
Geranium, Zonal
Geranium, Interspecific
Impatiens, New Guinea
Petunia, Trailing
Petunia, Spreading
Petunia, Miniature Trailing
Impatiens, Interspecific New Guinea
Mum, Garden
Mum, Pot
Combinations, Vigorous';
$subst = "\2 \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;