# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)(-)(\d{1})(.[^.]+)$/\1\20\3\4/gm;t' <<< "P123456_1_flying-elephant-100x70-1.pdf"