const regex = /^(.*)(-)(\d{1})(.[^.]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)(-)(\\d{1})(.[^.]+)$', 'gm')
const str = `P123456_1_flying-elephant-100x70-1.pdf`;
const subst = `\1\20\3\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);