use strict;
my $str = 'P123456_1_flying-elephant-100x70-1.pdf';
my $regex = qr/^(.*)(-)(\d{1})(.[^.]+)$/mp;
my $subst = '\\1\\20\\3\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";