using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)(-)(\d{1})(.[^.]+)$";
string substitution = @"\1\20\3\4";
string input = @"P123456_1_flying-elephant-100x70-1.pdf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}