package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)(-)(\d{1})(.[^.]+)$`)
var str = `P123456_1_flying-elephant-100x70-1.pdf`
var substitution = "\1\20\3\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}