import Foundation
let pattern = #"^(.*)(-)(\d{1})(.[^.]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"P123456_1_flying-elephant-100x70-1.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\20\3\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)