re = /^(.*)(-)(\d{1})(.[^.]+)$/m
str = 'P123456_1_flying-elephant-100x70-1.pdf'
subst = '\\1\\20\\3\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result