using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{[a-z]+:ce_img:(?:single|pair)?([\w\W\s]+)*}";
string substitution = @"$1";
string input = @"{eggs:ce_img:single
src=""{src}""
fallback_src=""/assets/a-b-c.jpg""
width=""250""
height=""250""
add_dims=""no""
crop=""yes""
title=""{title}""
alt=""{title}""
allow_scale_larger=""yes""
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}