// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{[a-z]+:ce_img:(?:single|pair)?([\w\W\s]+)*}").unwrap();
let string = "{eggs:ce_img:single
src=\"{src}\"
fallback_src=\"/assets/a-b-c.jpg\"
width=\"250\"
height=\"250\"
add_dims=\"no\"
crop=\"yes\"
title=\"{title}\"
alt=\"{title}\"
allow_scale_larger=\"yes\"
}";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}