import Foundation
let pattern = #"{[a-z]+:ce_img:(?:single|pair)?([\w\W\s]+)*}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{eggs:ce_img:single
src="{src}"
fallback_src="/assets/a-b-c.jpg"
width="250"
height="250"
add_dims="no"
crop="yes"
title="{title}"
alt="{title}"
allow_scale_larger="yes"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)