use strict;
my $str = '{eggs:ce_img:single
src="{src}"
fallback_src="/assets/a-b-c.jpg"
width="250"
height="250"
add_dims="no"
crop="yes"
title="{title}"
alt="{title}"
allow_scale_larger="yes"
}';
my $regex = qr/{[a-z]+:ce_img:(?:single|pair)?([\w\W\s]+)*}/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";