re = /{[a-z]+:ce_img:(?:single|pair)?([\w\W\s]+)*}/
str = '{eggs:ce_img:single
src="{src}"
fallback_src="/assets/a-b-c.jpg"
width="250"
height="250"
add_dims="no"
crop="yes"
title="{title}"
alt="{title}"
allow_scale_larger="yes"
}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result